主页spacer>软件支援>Mergemill Pro 快速入门指南

spacer

学习使用 Mergemill Pro 的一个好办法,就是逐步观察它的运作过程。安装的软件包巳包括一个简单的例子:Mergemill Pro > Mergemill Resources > Examples > 简体中文 > 简单案例。此外,这两篇重要文章也值得一读:Mergemill Pro 的连接设定有关文本编码的一些须知


概览

Mergemill 将模板的静态内容与数据馈送合并生成你想要的输出。你在模板中嵌入特殊标签,指定如何从馈送中插入内容。

模板内类似 <?[占位栏名称]?> 的标签主要以插入内容为目的。所有放置于对应的 <?Loop?> 及 <?EndLoop?> 标签之间的占位栏属于「循环内占位栏」,其余的为「循环外占位栏」。数据馈送内容插入占位栏可直接插入提取之数据值,或插入动态生成的数据值。

当你在 Mergemill Pro 设定一个合并作业,你须指定一个相关的模板,并按下一个按钮来解析它。在模板中发现的每一个新的占位栏名称,Mergemill Pro 会自动为其尸在相关作业之下添加一个任务定义,让你设定该占位栏自数据馈送提取内容的数据列,或指定数据值是如何动态地生成。

当你运行一个作业,其相关模板会被重复执行,直到用尽所有主要的数据馈送。模板每次运行时,Mergemill Pro 将模板中的所有静态内容复制到输出,并从指定的数据源提取相应的数据值来取代每个占位栏,生成完整的输出。视乎你设定的作业输出选项,当 Mergemill Pro 达到模板的终结,便会生成下列一个输出:合并后的文本转换成语音、群发自定义的合并电邮、合并后的文本存储为文档、使用合并后的数据来更新 SQL 数据源、或导出数据到 CSV 或 XML 文档。


启动

Mergemill Pro 启动后,主视窗便会出现。视窗的标题显示当前 Mergemill 文件的名称。

要启用 Mergemill Pro 的所有功能,你需要在「偏好设定」视窗内输入有效的软件授权密钥。要显示「偏好设定」视窗,在 Mac 上可选 Mergemill Pro > Preferences... 选单项目,在 Windows 上,可选 Help > Preferences... 选单项目。如没有一个有效的软件密钥,Mergemill Pro 运行时将有以下限制:

  1. 每个占位栏只会使用最多 50 个数据值。
  2. 专案的自动运行功能只运作一小时。
  3. [导入...] 按钮停用。
  4. 每个新建 Mergemill 文档只容许 [运行专案] 及 [运行作业] 按钮被使用 30 天。

请注意:未经授权的 Mergemill Pro 软件会通过读取在我们网站的日期字符串来监察 Mergemill 文件的有效期。除了这一小块数据的请求被群发到我们网站,绝对没有其他的数据传送。巳被授权密钥激活的 Mergemill Pro 除获取我们的在线文档和检查软件更新外,不会与我们的网站联系。


辅助选单项目

要了解每个用户界面元素的用途,可选择 Mergemill Pro 选单项目:「帮助 > 显示辅助提示」。如要快速查找标签语法,你可选择选单项目:「帮助 > Mergemill 标签指南」及「帮助 > 正则表达式指南」。


用户界面的输入控制

当你输入或指定设定值时,用户界面的元素和页面会被适当地启用和禁用,以免你因无关的物件而分心。例如,只有当你选择了专案作业列表上的一项作业,作业设定的页面才会被激活。同样,只有当你选择了作业任务列表上的一项任务,适当的数据馈送设定页面才会被启用。


红点除错导引

Mergemill Pro 的功能设计是要让用户轻易建立复杂的作业和其相关任务。一个例子是其「红点系统」,以提醒你在作业和任务设定的错误。只要按照红点逐一修复,你便可轻松地创建有效的作业定义。这使你可以专注於模板设计,创造有效的解决方案,解决实际问题。


Mergemill 模板

一个 Mergemill 模板包含要输出的所有静态文字,再加上 Mergemill Pro 要执行的指令标签。你当用一个简单的文本编辑器或 Adobe Dreamweaver 来创建或编辑模板,而不应使用类似 Microsoft Word 的软件应用程式,因为後者嵌入了隐藏的字符,令你的模板内看似正确的 Mergemill 标签实际上是 Mergemill Pro 无法识别的。

创建模板时应紧记所有占位栏标签皆会插入内容,无论是动态生成或从数据馈送读取的,整个处理模板的结果将是相关作业的输出。也请记住,所有作业和任务设定中的过滤、数据处理、查找替换及排序动作皆会在运行模板之前被应用到读取的数据值。

如果你编辑当前模板和再次解析它,一些占位栏可能已被删除或其名称已被更改。Mergemill Pro 不会自动删除这些占位栏的任务设定,以防你需要它们作为参考,或稍後改变主意,在模板内再次使用它们。这些占位栏名称会被加插「X:」作为标记。你可随时使用「删除休眠中的任务」按钮来删除这些占位栏任务设定。Mergemill Pro 运行作业时会略过所有处於休眠状态的任务。


生成静态网页的工作流程

  1. 工作流程应尽量有条理。先在「作业」文件夹内创建「模板」、「数据源」及「输出」子文件夹。
  2. 创建模板:
    • 制作一个样本网页,作为一个具体的输出目标,并将其复制到「模板」文件夹。
    • 决定哪些数据元素将被插入到网页内,以 Mergemill 占位栏标签取代那些部分,如 <?[城镇名称]?>,以便由数据源提供内容。
    • 加入其他所需的指令标签,如 <?Loop?>...<?EndLoop?> 及 <?If(...)?> 等,以控制如何将数据值插入。
  3. 将输出所需的辅助档案,如 GIF 图像,复制至「输出」文件夹内。Mergemill Pro 会自动创建输出文档路径中所有非现有的子文件夹,但你必须确保在生成的网页内所有超连结的正常运作。
  4. 添加一项作业,并指定修改後的样本网页为模板,然後按一下 [解析模板内容] 按钮。於模板中发现的每一个新占位栏标签名称,Mergemill Pro 会自动为其在当前作业内添加一个任务定义,让你可指定每个占位栏标签应从哪个数据馈送的哪个数据列提取内容,或指定数据值是动态生成的。
  5. 测试运行作业。Mergemill Pro 会读取数据值,进行过滤、处理及查找替换的行动,然後对数据进行排序,然後它会将所有模板的静态内容复制至你的输出,并以适当的处理後数据值取代每个占位栏标签,生成输出。
  6. 测试运行和编辑你的模板,直至达到你想要的结果。
  7. 重复步骤 2 至 6 去运行每个模板。


其他作业的工作流程

  1. 工作流程应尽量有条理。先在「作业」文件夹内创建「模板」、「数据源」及「输出」子文件夹。
  2. 制作一个输出样本,作为一个具体的输出目标。
  3. 用一个简单的文本编辑器编辑模板。
  4. 添加一项作业,并指定编辑好的模板,然後按一下 [解析模板内容] 按钮。於模板中发现的每一个新占位栏标签名称,Mergemill Pro 会自动为其在当前作业内添加一个任务定义,让你可指定每个占位栏标签应从哪个数据馈送的哪个数据列提取内容,或指定数据值是动态生成的。
  5. 测试运行作业。Mergemill Pro 会读取数据值,进行过滤、处理及查找替换的行动,然後对数据进行排序,然後它会将所有模板的静态内容复制至你的输出,并以适当的处理後数据值取代每个占位栏标签,生成输出。视乎你的作业设定,每当 Mergemill Pro 到达模板的结尾,便会产生下列其中一个输出:将合并後的文本转成语音、发送合并後的电邮、储存合并後的文档至指定位置、用处理後的数据更新 SQL 资料库或将处理後的数据汇出到制表符分隔或 CSV 或 XML 格式的文档。
  6. 测试运行和编辑你的模板,直至达到你想要的结果。
  7. 重复步骤 2 至 6 去运行每个模板。

spacer

返回页首

软件功能spacer::spacer下载专区spacer::spacer购买spacer::spacer软件支援spacer::spacer视频教程spacer::spacer标签指南spacer::spacer网站导览


版权所有 · 不得转载 © 2001-2017 Cross Culture Ltd.